Ticket Change Details
Overview

Artifact ID: 1f68385a6fae249cfd4f5e12aa39860b85616d7e
Ticket: 1e7f92c8ba6be442845f57fa3795d97a67cf60c6
Add tclbdd to KitCreator battery
User & Date: mr_calvin on 2020-09-09 11:13:33
Changes

  1. Change comment to:
    Please add tclbdd to the KitCreator battery. See branch [mr_calvin-tclbdd] for the implementation of a build.sh (it uses the new KC format). I tested successfully using:

     KITCREATOR_PKGS='tcllib tclbdd'; export  KITCREATOR_PKGS
    ./kitcreator

     KITCREATOR_PKGS='tcllib tclbdd kitdll';  export KITCREATOR_PKGS
    ./kitcreator

    w/ and w/o --enable-64bit. w/ and w/o explicit Tcl version (8.6.10)

    Some remarks:
    • tclbdd does not support static kit builds (right now): _TclTomMathInitializeStubs symbol not found
    • tclbdd has a runtime dependency on tcllib: grammar::aycock package (this cannot be signalled in KC, I figured)




  2. Change foundin to "trunk"
  3. Change login to "mr_calvin"
  4. Change private_contact to "d4d1d8192a46acf2c7d58cddc1040ecdbc9c9d77"
  5. Change severity to "Important"
  6. Change status to "Open"
  7. Change title to "Add tclbdd to KitCreator battery"
  8. Change type to "Feature Request"